WordPress计划2017年中将PHP推荐版本从5.6升级到7.0

分享本文:
php-7-wordpress
WordPress计划2017年中将PHP推荐版本从5.6升级到7.0
4 分, 共 3

HP在过去的数年中,WordPress的用户和站长几乎从不需要了解太多的技术支持,就可以运行WordPress网站。这也导致有批评称,WordPress带来了技术上不负责任的问题,因为站长根本不需要知道他的网站运行在哪个PHP版本之上。

这篇批评WordPress的文章发表在这里:WordPress crusade against technical responsibility

WordPress更新推荐安装环境

大约3个月前,WordPress官网更新了WP安装环境对主机的推荐要求。在更新之前,WordPress安装环境的最低要求是PHP 5.2或更高版本。更新之后,WordPress安装环境的推荐要求是PHP 5.6或更高版本,但后面依旧注明,可以在PHP  5.2.4版本以上的环境中运行。

WordPress对安装环境的宽松需求,是其取得成功的关键因素之一,因为它几乎可以运行在所有的主机空间服务器上。比如,有些主机服务商的服务器上使用甚至还是PHP 5.2版本,也可以正常安装WordPress最新版。

然而,随着PHP新版本的发布,旧版本的PHP将陆续退出官方维护期。也就是说,即使发现旧版本的PHP中存在漏洞,也不会再进行修复。这对于运行在旧版本PHP之上的网站来说,存在极大的安全隐患。

WordPress团队一致在努力解决网站的安全性问题,他们也曾因此受到过表彰。但是,如果PHP本身存在问题,那么WordPress团队也将无能为力。

因此,许多WordPress专家、开发者建议将推荐的PHP版本升级到7.0。

为什么要升级到 PHP 7 ?

早在PHP 7发布之前,WordPress就在为支持PHP 7做着准备。WordPress在PHP 7环境下,性能有着非常显著的提升。WordPress中文网提供的WordPress专业主机,全面支持PHP 5.2 ~ PHP 7各个版本,有兴趣的用户可以自行切换到PHP 7版本,体验飞速网站的感觉。

但是,有一些主要的插件,比如WP官方的WordPress Importer(内容导入器)插件,仍然不能兼容于PHP 7版本。因此,在PHP 5.6的声明周期内,WordPress会鼓励开发者积极测试、改进插件主题在PHP 7环境中的兼容性。

所以,WordPress 4.6的开发负责人,Dominik Schilling 说

考虑到PHP 5.6版本的官方支持时间表,我们最迟将在WordPress 4.8的时候提升PHP推荐版本;那么我们正好利用剩下的几个月时间来改善WordPress生态系统在PHP 7下的用户体验。

WordPress 创始人 Mullenweg 说,WordPress 不会利用其市场份额来向Web主机空间服务商施压;而是建立联系来引导升级到 PHP 7。为了让用户关注PHP版本对网站的影响,WordPress 将会采取一些持续的措施,对用户进行积极教育。

WordPress计划2017年中将PHP推荐版本从5.6升级到7.0
4 分, 共 3
分享本文:


评论: WordPress计划2017年中将PHP推荐版本从5.6升级到7.0

发表一下评论

电子邮件地址不会被公开。 必填项已用*标注

Menu Title