WordPress 插件兼容性检查工具

分享本文:
请为本文打分

WordPress 又发布新版本了,这是一个令人头疼的问题。每次 WordPress 升级,我们都要考虑,我们的插件能否在新版本的 WordPress 下工作正常。

我见过许多网友因为这个原因而推迟升级 WordPress 。WordPress 官方文档为维护了一个不同版本下兼容性的插件列表。WordPress 插件兼容检查工具则是一个对插件进行索引并提供兼容性检查的服务。

这个插件提供了一个检查插件兼容性的办法;不过在考虑是否升级的时候,这个工具提供给你的只是参考性意见,而不是做出判断的依据。WordPress 文档中的插件兼容性部分是最为精准的途径。

这个插件兼容性检查工具现在索引了超过7500个插件,其中5040个插件完全兼容于 WordPress 2.8

这个工具使用了几个标准来判断是否兼容,包括支持的 WordPress 最低版本和最高版本,是否已经被硬编码入 WordPress,是否兼容 PHP4,是否直接连接数据库而没有使用 WordPress 所提供的 DB 对象等。

如果你是一个插件开发者,你可以使用这个工具来看看插件是否有问题。

这个兼容性结果是使用工具来提供的,并且精准结果,因此只能用于参考。WordPress 文档提供的兼容性列表示检查插件是否兼容于 WordPress 2.8 的确切途径。感谢 Alex

原文:WordPress Plugin Compatibility Checker

中文:WordPress 插件兼容性检查工具 by WordPress 非官方中文站

请为本文打分
分享本文:


评论: WordPress 插件兼容性检查工具

  • 应该说一个还要靠人工检查的兼容性表吧,工具似乎说不上!

    ludou 2009/08/29 9:04 上午 回复
  • 哦,这个工具还是很有用的

    Jiang 2009/08/31 8:19 上午 回复
  • 都是好东西啊 !

    jaycn 2009/10/29 12:17 下午 回复
  • Pingback: WordPress 插件兼容性检查工具 | 十年电商

发表一下评论

电子邮件地址不会被公开。 必填项已用*标注

Menu Title