为什么我的网站被升级到WordPress 4.1.3?

分享本文:
wp-41
请为本文打分

昨天在WordPress 4.2正式版发布之后,我们主机的一个用户在QQ群里问我这样一个问题,为什么他的WordPress被升级到WordPress 4.1.3了。不管是WordPress核心开发团队的博客,还是专门对外发布新闻的WordPress官方博客中,都没有提到这一版本。不过,WP官方文档中已经增加了WordPress 4.1.3的发布说明,介绍了发布此版本的原因。

WordPress 4.1.3的发布说明中是这样描述的:

Fix database writes for esoteric character sets, broken in the WordPress 4.1.2 security release. Neither UTF-8 nor latin1 were affected. For more information, see ticket #32051.

大意是说,就是修复了一些使用某些罕见字符集出现的数据库错误,这是发布WordPress 4.1.2安全更新版本时引入的新问题。不过,使用utf8和latin1(两种常见的字符集)未受影响;因此,绝大部分中文网站都是用utf8编码格式,不会受到此问题的影响。当然,不管怎样,我们还是建议你及时更新到最新版本。

在上面的ticket讨论中,有更为详细的技术性讨论,有兴趣的话可以看看。除了WordPress 4.1.3,还有其他一些版本也针对此bug进行了升级,包括有:

  • 3.7.7
  • 3.8.7
  • 3.9.5
  • 4.0.3

这些都是针对出现bug而发布的修正版本更新。如果你使用的WordPress版本高于3.7,WordPress将会自动为你更新到相应的补丁版本,除非你手动关闭了自动更新功能。如果你还在使用更早的版本,wpchina.org建议你现在升级到最新的WordPress 4.2版本

请为本文打分
分享本文:


发表一下评论

电子邮件地址不会被公开。 必填项已用*标注

Menu Title