WordPress 3.2 将放弃 PHP4 和 MySQL4 平台

分享本文:
WordPress 3.2 将放弃 PHP4 和 MySQL4 平台
请为本文打分

WordPress 开发者一直致力于让WordPress可以运行于更多的主机环境中,可以让用户自由地选择虚拟主机。然而时过境迁,现在的虚拟主机环境变化了许多,为了更好地运行WordPress,开发团队决定改变策略:从WordPress 3.2开始,将不再支持PHP 4和MySQL 4主机环境

首先要说明的是,即将于2010年底发布的WordPress 3.1,仍将支持PHP 4环境,也将是最后一个支持PHP 4的版本。

计划于2011年上半年发布的WordPress 3.2,所需要的PHP最低版本将是5.2。为什么选择PHP 5.2?根据调查显示,大部分用户所使用的主机都高于这个版本,而且包括了PHP 5早期版本所没有的重要功能。同时,Drupal和Joomla下一版本所需要的PHP最低版本也是PHP 5.2。

根据调查,目前只有11%的用户,所使用的是PHP 4环境。目前的大部分主机都支持PHP 5.2,有些同时支持PHP 4和PHP5的主机,需要你在主机控制系统里激活PHP 5.2即可。因此,相信到 WordPress 3.2 发布之时,使用PHP 4的用户将进一步减少。

WordPress 3.1仍然可以同时在MySQL 4环境下运行。目前仍有6%的用户使用MySQL 4。在WordPress 3.2及以后版本中,所需要的MySQL最低版本MySQL 5.0.15。

因此,如果你所使用的主机不支持PHP 5.2及MySQL 5.0.15,你将无法升级到WordPress 3.2。WordPress内置的更新功能也将阻止你升级。如果你不确定你的主机是否能够支持将来的WordPress 3.2,你可以下载这个Health Check插件测试一下。如果你的主机不支持,那就应该尽早考虑换一个支持WordPress 3.2的新主机。随着运行环境的提升,WordPress也将会给我们带来一些新的功能,新的体验。

WordPress 3.2 将放弃 PHP4 和 MySQL4 平台
请为本文打分
分享本文:


评论: WordPress 3.2 将放弃 PHP4 和 MySQL4 平台

  • 占个首位,嘿嘿……
    怎么查看自己主机的PHP版本和MySQL 版本?

    liveme 2010/12/14 3:38 下午 回复
  • 嘿,查看到了,我现在使用的PHP版本是5.2.14,MySQL 版本是5.1.53,看来没有必要担忧。

    liveme 2010/12/14 3:41 下午 回复
  • 查到了,我的PHP和MySQL 版本都超过5.1

    liveme 2010/12/14 3:43 下午 回复
  • 很不错啊········

    万艾可效果 2010/12/15 7:50 下午 回复
  • 呵呵,支持就放心了。

    Jiang 2010/12/15 8:35 下午 回复
  • WP3.1正式版什么时候发布呀?

    丝婷 2010/12/22 11:16 下午 回复
  • 现在大多主机都装的是PHP5、MySQL5的啦。

    自在 2011/04/21 1:24 下午 回复
  • 这个都是不会太脱离使用者的,放心

    gzdodo 2011/05/18 2:40 上午 回复
  • Pingback: WordPress 3.2, 你准备好了吗? | 软兔兔り

  • Pingback: 爱破戒” » WordPress 3.2

  • This article is GREAT it can be EXCELLENT JOB and what a great tool!

    Microsoft Office 2010 2011/12/13 3:40 下午 回复
  • but he is very exact to his life. He is a regular planner in his life, loving initiative, occasionally carnival.

    Nike UK 2012/06/18 10:09 上午 回复
  • Pingback: WordPress 非官方中文站 » 相关新闻 » WordPress 3.2, 你准备好了吗?

发表一下评论

电子邮件地址不会被公开。 必填项已用*标注