禁止 WordPress 核心程序更新提示

分享本文:
禁止 WordPress 核心程序更新提示
请为本文打分

WordPress 的核心程序更新提示功能,是从 WordPress 2.3 开始增加的特色功能;在 WordPress 2.5 中,仍然有此功能。当你有新的 WordPress 版本发布的时候,在你的管理后台就会看到新版 WordPress 已经发布,提示你即使更新。

这是 WordPress 的核心功能之一。但是,对于不愿意立即升级的网站和用户而言,这个功能反而干扰了正常的使用。因此,WordPress 应该提供参数,允许用户自行关闭此功能。

那么,如何禁止掉 WordPress 自动提示功能呢?有以下几种办法可以供参考:

1. 修改 css 代码,隐藏更新提示信息;

找到 <WordPress安装目录>/wp-admin/wp-admin.css 文件中的 #update-nag 部分,添加代码:display: none; (注意,;号不可省略)。

2. 修改 php 代码,不输出更新提示信息:

找到 <WordPress安装目录>/wp-admin/update.php 文件中的 echo “<div id=’update-nag’>$msg</div>”; 代码,删除或注释掉。

3. 使用插件,禁止更新提示功能(推荐):

这是最为简单,也不容易出错的办法。那就是直接使用 Disable WordPress Core Update 插件。

这个插件很简单,只有两行代码。解压缩之后上传到插件目录,并通过插件面板启用,即可。

如果依然没有生效,那么将这个插件的第一行代码修改为:

add_action( 'init', create_function( '$a', "remove_action( 'init', 'wp_version_check' );" ),2);

这样讲提高这个操作的优先度,就应该可以禁止更新提示功能了。

禁止 WordPress 核心程序更新提示
请为本文打分
分享本文:


评论: 禁止 WordPress 核心程序更新提示

  • 2.5的还是等等再说,听说也不是很稳定呀。

    卡当 2008/04/01 4:31 下午 回复
  • @嗯,不必着急升级。

    Jiang 2008/04/01 11:39 下午 回复

发表一下评论

电子邮件地址不会被公开。 必填项已用*标注